We are pleased to inform you that the technical issues affecting the availability of administrative services, including the self-service portal, have been resolved. The disruption was caused by network problems, which have now been addressed, and all services are fully operational once again.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the issue.
Thank you for your understanding.
Best regards, Punktum dk
Posted Nov 26, 2025 - 09:53 CET
Investigating
We are currently experiencing general unavailability of administrative services.
We will investigate and return with new info as soon as possible.
Posted Nov 26, 2025 - 06:23 CET
This incident affected: Self-Service Portal, Registrar Portal, Whois (web), Whois (text), Whois API, EPP (Extensible Provisioning Protocol), DAS (Domain Availability Service), Administrative services, Zonemaster, Stats, and Sandbox environment.