Verification is currently underway for the maintenance items.
Posted Sep 24, 2026 - 11:11 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 24, 2026 - 10:00 CEST
Scheduled
Punktum dk is releasing a new version of the Self-Service Portal with improvements to e-mail login and ID control. The release makes sure that login links in e-mails keep working and that reminder e-mails always contain the link that the registrant needs.
Self-Service Portal Version 6.15.0 will be made available in our production environment on September 24, 2026 at 10:00 CEST.
Affected Services • Self-Service Portal Version 6.15.0
Expected Impact • No downtime is expected during this maintenance window.
Changes Included (Self-Service Portal) • E-mail login links now keep working when an e-mail security service checks the link before the user opens it - Before, an automatic check could use up the one-time link, and the user had to request a new one • Reminder e-mails for ID control by e-mail now always include the link to the page where the registrant checks and confirms their data • The "Change name servers" option on the domain page is now only shown to users who are allowed to request a name server change - Registrants and proxies no longer see this option • Minor text corrections