We are currently experiencing issues with invoice processing

Incident Report for .dk

Identified

Dear subscribers

We have identified the cause of the issue affecting invoice processing.

Invoices are still not being sent to customers and cannot currently be downloaded from our self-service portal or registrar portal.

We expect to have a solution ready tomorrow.

We apologize for the inconvenience and thank you for your patience.

Best regards
Punktum dk
Posted Jul 06, 2026 - 16:00 CEST

Investigating

Dear subscribers

The issue has been ongoing since Saturday, 4 July, at approximately 18:00 CEST.

As a result, invoices are not being sent to customers, and invoices cannot currently be downloaded from our self-service portal or registrar portal.

We are investigating the issue and will provide an update as soon as more information is available.

Best regards
Punktum dk
Posted Jul 06, 2026 - 13:36 CEST
This incident affects: Self-Service Portal and Registrar Portal.